Hosted Name

Incident

Degraded performance across UK name servers

Resolved | Apr 25, 2018 | 21:20 GMT+01:00

We have isolated and resolved the issue causing slower than usual DNS lookups.

Please feed back to hello@hosted.name if you experience any issues.

Affected components

  • Domain Name Servers

Investigating | Apr 25, 2018 | 20:51 GMT+01:00

We are aware of an issue with our core network in London based on servers provided by Digital Ocean which is causing DNS queries to take longer than usual to respond.

We hope to resolve this issue within our standard SLA.

Status Page powered by Admin Labs